Cato Networks Knowledge Base

Upgrading Cato Windows VPN Client

  • Updated

This article describes the steps for installing Cato Windows VPN Client.

In the following table you can find a list of known upgrade issues:

From Version

To Version

Comments

Any EXE

Any EXE

No known issues

MSI 4.0 or earlier

MSI 4.2 or later

No known issues

MSI 4.1, 4.2 

MSI 4.2, 4.3 

Uninstall the old version before installing the new version

MSI 4.2 or earlier

EXE 4.3 or earlier

Not recommended

EXE 4.2 or earlier

MSI 4.3 or earlier

Not recommended

Any

MSI 4.4 or EXE 4.4

No known issues

For more about installation interruption on Windows 2012/8.x, see Troubleshooting Cato VPN Client InstallShield Interruption on Windows Server 2012 / 8.x.

Installing the Cato Client

This section describes the Cato Client installation options. Follow the option that is relevant for the versions that you are installing.

Note: the installation limitations that are described in this article are fixed in version 4.4. Contact your sales representative for more information about the release plan of version 4.4.

Initial Installation of the Cato Client

If you are installing a fresh installation of the Cato Client, use one of the following options:

  • Running the EXE file in Explorer
  • Running the EXE file using the command line: <setup_file.exe>
    • For quiet installation use the command line: <setup_file.exe> /s /x /v"/qn"
    • Prerequisite: The MSI installation requires MS .NET framework installed 
  • Running the MSI file using the command line: msiexec /i <setup_file.msi>

Upgrade the Cato Client (From EXE To EXE):

If you are upgrading the Cato VPN Client (from EXE to EXE file), use one of the following options:

  • Running the EXE file in Explorer
  • Running the EXE file using the command line: <setup_file.exe> /s /x /v"/qn"

Upgrade the Cato Client (From MSI to MSI):

If you are upgrading the Cato VPN Client (from MSI to MSI file), use the following options:

  • Upgrading from version 4.0 or earlier to version 4.1 MSI, use the command line: msiexec /i <setup_file.exe>.msi

Starting From Version 4.4

The following options are available to upgrade the Cato VPN Client starting from version 4.4 (for MSI or EXE files):

Upgrading MSI / EXE to an EXE File

If you are upgrading version 4.4 or later from MSI or EXE to EXE file, use one of the following options:

  • Running the EXE file in Explorer
  • Running the EXE file using the command line: <setup_file.exe> /s /x /v"/qn"

Upgrading MSI / EXE to an MSI File

If you are upgrading version 4.4 or later from MSI or EXE to MSI file, use the following command:

  • Running the MSI file using the command line: msiexec /i <setup_file.msi>

Troubleshooting Cato VPN Client Installation Issues

If the VPN client upgrade fails, use the Troubleshooting Cato Windows VPN Client Installation Issues article.

Known Limitations

Installing and Upgrading Windows 7 32-bit

Note: As of Windows Client 4.5, Cato no longer supports installing the Client on Windows 7.

When you are installing the Cato Client versions 4.3.10 and 4.4.18 on Windows 7 32-bit operating system, the following limitations apply:

  • After installing the Client, the User Account Control window shows the publisher name as Unknown instead of Cato Networks.

  • When you upgrade from a Windows Client that is earlier than version 4.4, even with Never-off enabled, the computer remains connected to the VPN and the Client isn't opened.

Was this article helpful?

2 out of 5 found this helpful

Comments

0 comments

Please sign in to leave a comment.