Solución de problemas de tiempo de carga prolongado de páginas web y problemas de renderizado

Problema

Las aplicaciones web son de las más utilizadas hoy en día debido a su accesibilidad, flexibilidad y conveniencia. Se pueden acceder desde cualquier dispositivo con conexión a internet, incluidos ordenadores de escritorio, portátiles, tabletas y teléfonos inteligentes, lo que las hace ideales para los usuarios que están en movimiento o que trabajan de forma remota.

Un problema de renderizado de página web puede provocar varios problemas, incluidos carga lenta de la página, carga incompleta de la página, o que la página no se cargue en absoluto. Es esencial solucionar y resolver rápidamente los problemas de renderizado para asegurar que los usuarios puedan acceder a las aplicaciones web sin problemas. Este artículo tratará algunas de las causas comunes del problema de renderizado de páginas web y cómo podemos realizar pasos de solución de problemas para aislar más el problema.

Causas posibles 

Hay numerosas razones por las que la página web no se renderizó o se renderizó muy lentamente. Algunas comunes son:

  • Ruta de enrutamiento subóptima al servidor
  • Cache y cookies del navegador corruptas/obsoletas
  • Problemas del servidor
  • Enlaces rotos o recursos faltantes
  • Bloqueo de contenido por bloqueadores de anuncios o firewalls

Solución de problemas 

Ruta de enrutamiento subóptima al servidor

La carga lenta de la página puede deberse a veces a rutas subóptimas hacia el servidor web. Para asegurar una ruta óptima entre el sitio y el servidor, podemos emplear los siguientes métodos sencillos para verificar la latencia. Al realizar una prueba de ping o traceroute, podemos comparar los resultados obtenidos cuando la conexión pasa a través de Cato, con los resultados obtenidos al omitir Cato por completo.

1. Ping  Puede usar el comando ping para verificar si el servidor web está respondiendo. Si el servidor es accesible, recibirá una respuesta del servidor con el tiempo de ida y vuelta (RTT). Si los valores de RTT son más altos cuando la conexión pasa a través de Cato, consulte Mayor latencia a través de Cato para más soluciones de problemas.

pingresponse.jpg

2. Traceroute Puede usar el comando traceroute para verificar la ruta que toma la conexión hacia el destino. El número de saltos mostrado en un traceroute no es el factor definitivo para determinar la velocidad de una conexión. En cambio, el tiempo de ida y vuelta (RTT) tiene mayor significado al evaluar la velocidad de la conexión.

El siguiente ejemplo resalta este escenario: aunque el número de saltos en la ruta de la red disminuye significativamente cuando la conexión pasa a través de Cato, el tiempo de ida y vuelta (RTT) es inesperadamente más alto en comparación con el resultado obtenido cuando la conexión se omite.

La siguiente conexión omitió Cato:

traceroute.jpg

Lo siguiente muestra la misma conexión, pero pasa a través de Cato:

traceroute1.jpg

NOTA: Al atravesar la nube de Cato, es común observar una reducción en el número de saltos. Esto se debe a que los saltos internos dentro de la infraestructura de la nube de Cato no se reflejan en los resultados de traceroute.

Mayor latencia a través de Cato:

Para abordar la mayor latencia cuando la conexión pasa a través de Cato, es esencial examinar las siguientes configuraciones:

Asegúrese de que el Socket se conecte al PoP más cercano

  • En el CMA, vaya a la pestaña de Monitoring y luego seleccione el sitio afectado
  • En el panel de la derecha, bajo Conexiones Recientes, haga clic en Ver Registro. Se abrirá otro panel con información sobre el PoP conectado.connectedPoP.jpg
  • Si no está conectado a un PoP más cercano a la ubicación del sitio, verifique si el socket se configuró manualmente para conectarse a un PoP preferido navegando a Network > Sites > Sites Configuration > General > Preferred PoP Locations
  • Si fue configurado incorrectamente al PoP equivocado, siga este Definir-un-PoP-preferido-para-un-sitio para establecerlo en el PoP más cercano, o configure la Ubicación Primary en Automático (por defecto) y el Socket seleccionará y se conectará al mejor PoP automáticamente.

Revisar si hay reglas de Egreso o Backhaul

  • En el CMA, vaya a Reglas de Network y examine la lista para verificar si hay alguna regla que se refiera al servidor web en cuestión, y tiene el método de enrutamiento configurado.
  • Si hay alguna, revise el PoP/Site de egreso configurado y evalúe su proximidad al servidor web.

  • Si el PoP/Site está ubicado lejos del servidor web, tiene dos opciones para optimizar la configuración:
    -- Modifique la regla de red existente eliminando la dirección IP del servidor web de la regla. Este cambio permitirá (por defecto) que el tráfico salga desde el PoP al que está conectado el socket. Sin embargo, es importante tener en cuenta que esto puede no ser siempre ideal, ya que el PoP directamente conectado puede no estar en estrecha proximidad al servidor web.
    -- Alternativamente, cree una nueva regla de red específicamente para el servidor web. En esta nueva regla, configure el egreso a un PoP/Site que esté más cerca de la ubicación real del servidor web.
    Consulte Cómo-Configurar-una-Regla-de-Egreso y Configurar-Backhauling-de-Tráfico-de-Internet para obtener instrucciones sobre cómo configurar una regla de egreso y backhauling de tráfico de Internet, respectivamente.

Cache y Cookie del Navegador Corruptas/Obsoletas

La cache y cookies del navegador a veces pueden provocar problemas de renderizado en una página web si los recursos almacenados en cache están desactualizados o corruptos. Esto puede suceder cuando un archivo CSS o JavaScript de una página web se actualiza, pero el navegador todavía utiliza la versión almacenada en cache, lo que resulta en un renderizado incorrecto o errores en la página. Para confirmar si esto resuelve el problema, el usuario puede intentar acceder a la página en modo incógnito. Si funciona en modo incógnito, los usuarios pueden borrar el cache del navegador y recargar la página. A continuación se presentan algunas de las formas de borrar el cache y las cookies del navegador para algunos de los navegadores más utilizados.

Google Chrome:

  • Abra Google Chrome y haga clic en el icono de tres puntos en la esquina superior derecha de la ventana.
  • Haga clic en "Más herramientas" y luego en "Borrar datos de navegación".
  • Seleccione el rango de tiempo que desea borrar y marque las casillas para "Cookies y otros datos de sitio" y
  • "Imágenes y archivos en caché".
  • Haga clic en "Borrar datos".

Mozilla Firefox:

  • Abra Firefox y haga clic en el icono de tres líneas en la esquina superior derecha de la ventana.
  • Haga clic en "Configuración" y luego en "Privacidad & Seguridad".
  • Desplácese hacia abajo hasta la sección "Cookies y Datos del Sitio" y haga clic en "Borrar Datos".

Apple Safari:

  • Abra Safari y haga clic en "Safari" en la barra de menú en la parte superior de la pantalla.
  • Haga clic en "Preferencias" o "Configuraciones" y luego en "Privacidad".
  • Haga clic en "Administrar Datos de Sitios Web".
  • Haga clic en "Eliminar Todo" y luego en "Hecho".

Microsoft Edge:

  • Abra Microsoft Edge y haga clic en el icono de tres puntos en la esquina superior derecha de la ventana.
  • Haga clic en "Configuraciones" y luego en "Privacidad, búsqueda y servicios".
  • Haga clic en "Elija qué borrar" en la sección "Borrar datos de navegación".
  • Marque las casillas para "Cookies y otros datos de sitios" y "Imágenes y archivos en caché".
  • Haga clic en "Borrar ahora".

Aislar más siguiendo el problema

En esta sección, exploraremos técnicas de solución de problemas que implican aislar el problema para identificar su causa raíz. Para ayudar con este proceso, considere hacer las siguientes preguntas:

  • ¿Esto está sucediendo solo en China?
  • Si la respuesta es 'Sí', consulte China | Página web con problemas de renderizado para determinar si este problema es causado por rastreadores o adware que son bloqueados por el Gran Firewall de China.
  • ¿Este problema solo afecta a un (grupo de) usuarios en particular?
    Si la respuesta es 'Sí', entonces necesitamos identificar cuál es la diferencia entre el dispositivo que este (grupo de) usuario(s) está utilizando en comparación con el resto.
  • ¿El problema ocurre solo en ciertas horas del día?
    Si es así, entonces necesitamos verificar el uso del ancho de banda y potencialmente la pérdida de paquetes durante ese período. Si vemos pérdida de paquetes durante este período, consulte Cómo-solucionar-la-pérdida-de-paquetes para más instrucciones de solución de problemas.
  • ¿El problema solo afecta a un sitio en particular?
    Si esto solo afecta a un sitio, entonces verifique si hay alguna regla de firewall/red que se origine desde el sitio afectado. Examine esas reglas para verificar si podrían estar contribuyendo al problema. 
  • ¿El problema solo ocurre cuando la conexión se origina desde un país en particular?
    Si esto también afecta a un país en particular, entonces es probable que esté relacionado con el bloqueo geográfico. Refer to Website Inaccessible due to Cato IP Blacklisting or Geo-Blocking for more details.
  • ¿El problema solo ocurre cuando la conexión pasa a través de Cato?
    Si la respuesta es 'Sí', entonces esto podría posiblemente deberse a la lista negra de IP. Consulte Sitios-web-que-listan-en-la-lista-negra-la-IP-de-Cato para más detalles.
  • ¿El problema ocurre solo en un navegador en particular?
    Si es así, esto probablemente se deba a un cache y/o cookie corrupto. También puede deberse a un navegador desactualizado. Intente navegar en modo incógnito y también actualice el navegador si es necesario. 
  • ¿El usuario necesita hacer clic en "Proceder" antes de avanzar al sitio web?
    Si aparece una página de aviso de Cato y la página web se carga parcialmente cuando el usuario hace clic en "Proceder", entonces esta es una limitación conocida. Consulte Sitios-web-con-página-de-aviso-no-se-cargan-correctamente para más detalles sobre esta limitación. 

Si ha llegado a esta sección del artículo, es probable que el problema de renderizado que está experimentando sea complejo y requiera la recopilación de datos para un análisis más detallado. HAR, o HTTP Archive, es un formato de archivo utilizado para capturar y registrar la interacción entre un navegador web y un sitio web. El siguiente paso implica la recopilación de datos HAR mientras se replica el problema. Estos datos proporcionarán información valiosa para un análisis más detallado, ayudando a identificar las posibles causas del problema de renderizado. Consulte Cómo-Recopilar-Datos-HAR para las instrucciones.

Una vez que haya recopilado los datos HAR, puede consultar Cómo-Usar-el-Archivo-HAR-para-Analizar-Problemas-de-Página-Web para los pasos detallados sobre cómo analizar eficazmente el archivo HAR recopilado. Esta guía le proporcionará las instrucciones necesarias para aislar e identificar el problema específico que causa el problema de renderizado.

Soporte de Cato

Si los pasos mencionados anteriormente no ayudaron a identificar y resolver el problema de renderizado de la página web, solicitamos amablemente su asistencia para recopilar los datos necesarios para una revisión más detallada por parte de nuestro equipo de soporte:

  • Recolecte SSS. Por favor, consulte Portal-de-Autosoporte-SoporteMe para instrucciones detalladas sobre cómo recopilar y proporcionar los datos necesarios para el Soporte.
  • Recolecte los datos HAR mientras el problema se replica y súbalos al caso de soporte. Consulte Cómo-Recopilar-Datos-HAR para instrucciones detalladas.

 

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