Solución de problemas del estado de HA de Socket

Visión general

Alta disponibilidad ofrece redundancia en caso de una interrupción crítica en un dispositivo socket. Un sitio debe poder transitar con éxito entre dispositivos socket en estos casos para asegurar la continuidad del negocio. Este libro de jugadas busca guiar la solución de problemas de este escenario.

Síntomas

La preparación insuficiente en el estado de HA del socket se puede manifestar de varias formas. Un administrador puede notar los siguientes síntomas:

  • Uno de los sockets del par de HA está fuera de línea.
  • Estado de HA no listo debido a 'Keepalive'.
  • Estado de HA no listo debido a 'Versión Compatible'.

Posibles Causas

  • Uno de los pares de HA tiene problemas de conectividad con Cato.
  • Los sockets carecen de conectividad del lado LAN entre ellos
  • Diferencias de firmware entre sockets

Solución de Problemas del Inconveniente

Los pasos para solucionar los síntomas que un Administrador puede encontrar se enumeran a continuación. Estos pasos están destinados a identificar posibles causas de los problemas enfrentados. Los pasos de resolución se destacarán más adelante en el libro de jugadas.

Solución de Problemas miembro de HA del socket fuera de línea

Por favor, siga nuestro Libro de Jugadas para Solución de Problemas de Conectividad del Socket.

 

Solución de Problemas Estado de HA No Listo Debido a 'Keepalive'

Estado de la Interfaz LAN

Los mensajes VRRP, el mecanismo para mantener el estado de HA entre un par de HA, requieren un camino de red entre las interfaces LAN de cada miembro. Asegúrese de que un puerto LAN está activo y disponible para mensajes VRRP. 

Verifique si hay cambios recientes en el conmutador o la configuración del lado LAN, como la configuración de VLAN o cambios en el cableado físico. Asegúrese de que su configuración siga las mejores prácticas para el HA del socket descritas en ¿Qué es la Alta Disponibilidad (HA) del Socket?.

 

Transmisión y Recepción de Tramas VRRP

Ejecute una captura de paquetes en la Interfaz LAN de ambos sockets, siguiendo el procedimiento listado en How to Take a Packet Capture on a Socket, y verifique si el Socket maestro está enviando mensajes VRRP de keepalive al Socket en espera.

Para que el estado de HA del socket esté listo, ambas condiciones siguientes deben ser verdaderas:

  • El socket primario debe estar enviando mensajes VRRP
  • El socket secundario debe estar recibiendo esos mensajes VRRP

Si el socket primario está enviando estos mensajes pero el secundario no los está recibiendo, investigue su infraestructura de red local para identificar si algo está impidiendo que lleguen al socket secundario.

 

Solución de Problemas Estado de HA No Listo Debido a 'Versión Compatible'

Si esto ocurrió debido a un fallo en la actualización del firmware, consulte el proceso para Túnel establecido después del fallo de actualización en el Libro de Jugadas para la Solución de Problemas de Fallo de Actualización del Socket.

 

Navegue a Resolviendo Versiones Incompatibles.

 

Resolviendo Problemas Descubiertos

Resolviendo Versiones Incompatibles

Un problema de conectividad momentáneo puede haber causado un fallo en la actualización y podría tener éxito la segunda vez. Para intentar una nueva actualización de Socket, inicie manualmente la actualización desde Configuración del Sitio > Socket > Acciones > Actualizar.

Asegúrese de que la versión objetivo llevará a que ambos sockets en el par de HA tengan la misma versión. Esta herramienta solo puede actualizar y no degradar la versión del firmware. 17 minutos después de que comience la actualización manual del firmware, CMA mostrará una notificación de "actualización exitosa" indicando que el Socket reportó una actualización exitosa después del período de gracia.

Si esta actualización también falla, utilice el Libro de Jugadas para Solución de Problemas de Fallo de Actualización de Socket.

 

Apertura de casos a Soporte de Cato

Si al seguir este libro de jugadas no se ha resuelto un problema, envíe un ticket de Soporte. Para obtener la respuesta más útil a una solicitud, un administrador debe proporcionar los resultados de los pasos de solución de problemas tomados a lo largo del uso de este libro de jugadas. Incluyendo, por ejemplo:

  • Confirmación de cualquier actualización manual que haya tenido lugar, incluyendo marcas de tiempo.
  • Confirmación de la transmisión y recepción de mensajes VRRP.
  •  
  •  

¿Fue útil este artículo?

Usuarios a los que les pareció útil: 0 de 0

0 comentarios