Dépannage de l'état HA de Socket

Vue d'ensemble

La haute disponibilité offre une redondance en cas de panne critique d'un appareil socket. Un site doit pouvoir passer avec succès d'un appareil socket à un autre dans ces cas afin d'assurer la continuité des activités. Ce guide vise à diriger le dépannage de ce scénario.

Symptômes

La non-préparation de l'état HA du socket peut se manifester de plusieurs manières. Un administrateur peut noter les symptômes suivants :

  • L'un des sockets du couple HA est hors ligne.
  • État HA non prêt en raison de 'Keepalive'.
  • État HA non prêt en raison de 'Version Compatible'.

Causes possibles

  • L'un des membres du couple HA a des problèmes de connectivité avec Cato.
  • Les sockets manquent de connectivité du côté LAN entre eux
  • Différences de firmware entre sockets

Dépannage du problème

Les étapes pour résoudre les symptômes qu'un administrateur peut rencontrer sont énumérées ci-dessous. Ces étapes visent à identifier les causes possibles des problèmes rencontrés. Les étapes de résolution seront mises en évidence plus tard dans le guide.

Dépannage du membre HA du socket hors ligne

Veuillez suivre notre Guide de Dépannage de la Connectivité du Socket.

 

Dépannage de l'état HA non prêt en raison de 'Keepalive'

État de l'interface LAN

Les messages VRRP, le mécanisme pour maintenir l'état HA entre un couple HA, nécessitent un chemin réseau entre les interfaces LAN de chaque membre. Assurez-vous qu'un port LAN est actif et disponible pour les messages VRRP. 

Vérifiez s'il y a des changements récents dans le commutateur ou la configuration côté LAN, comme la configuration VLAN ou des changements dans le câblage physique. Assurez-vous que votre configuration suit les meilleures pratiques pour le HA du socket décrites dans Qu'est-ce que la Haute Disponibilité (HA) du Socket?.

 

Transmission et réception des trames VRRP

Effectuez une capture de paquets sur l'interface LAN des deux sockets, en suivant la procédure listée dans Comment effectuer une capture de paquets sur un socket, et vérifiez si le socket maître envoie des messages VRRP de keepalive au socket de secours.

Pour que l'état HA du socket soit prêt, les deux conditions suivantes doivent être vraies :

  • Le socket primaire doit envoyer des messages VRRP
  • Le socket secondaire doit recevoir ces messages VRRP

Si le socket primaire envoie ces messages mais que le secondaire ne les reçoit pas, examinez votre infrastructure réseau locale pour identifier si quelque chose empêche leur arrivée au socket secondaire.

 

Dépannage de l'état HA non prêt en raison de 'Version Compatible'

Si cela s'est produit en raison d'un échec de mise à niveau du firmware, veuillez consulter le processus pour Tunnel établi après l'échec de mise à niveau dans le Guide de Dépannage de l'Échec de la Mise à Niveau du Socket.

 

Accédez à Résolution des Versions Incompatibles.

 

Résolution des problèmes découverts

Résolution des Versions Incompatibles

Un problème de connectivité momentané peut avoir causé un échec de mise à niveau et pourrait réussir la deuxième fois. Pour tenter une nouvelle mise à niveau des sockets, lancez manuellement la mise à niveau depuis Configuration du Site > Socket > Actions > Mettre à niveau.

Assurez-vous que la version cible entraînera les deux sockets du couple HA à avoir la même version. Cet outil peut uniquement mettre à niveau et non rétrograder la version du firmware. 17 minutes après le début de la mise à niveau manuelle du firmware, le CMA affichera une notification "mise à niveau réussie" indiquant que le Socket a signalé une mise à niveau réussie après la période de grâce.

Si cette mise à niveau échoue également, utilisez le Guide de Dépannage de l'Échec de Mise à Niveau de Socket.

 

Soumettre des cas au Support Cato

Si suivre ce guide n'a pas résolu un problème, soumettez un ticket de Support. Pour obtenir la réponse la plus utile à une demande, un administrateur devrait fournir les résultats des étapes de dépannage entreprises tout au long de l'utilisation de ce guide. Incluant, par exemple :

  • Confirmation de toute mise à niveau manuelle effectuée, y compris les horodatages.
  • Confirmation de la transmission et de la réception des messages VRRP.
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