問題
場合によっては、ブラウザ拡張機能が接続されていると、特定の AI アプリケーションでは AI セキュリティ ポリシーが適用され、一部のアプリケーションでは適用されません。 たとえば、ChatGPT にはポリシーが適用されても、Microsoft Copilot には適用されないことがあります。同じポリシーにアプリケーションが有効化されていてもです。 この動作の背後にある理由を探ります。
注意: このケーススタディは、AI セキュリティの文脈での Cato ブラウザ拡張機能 に焦点を当てており、AI セキュリティ ブラウザ プラグイン と混同しないようにしてください。
根本原因
Cato ブラウザ拡張機能は現在、HTTPS トラフィック のみをサポートしています。 非 HTTPS トラフィックは Cato を経由せず、したがって AI セキュリティ ポリシーを適用することができません。
トラブルシューティング
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関連するトラフィックについて、ユーザー インタラクション ポリシーの下でポリシーが設定されていることを確認します。 CMA で、AI セキュリティ > ユーザー インタラクション ポリシー に移動します。 ブラウザ拡張機能のユースケースについては、ポリシーがネットワークルールを対応タイプとして明確に定義されていることを確認します。
- アプリケーションが Cato によってサポートされていること、およびネットワークインターセプトルールのドロップダウンにリストされていることを確認します。
- 最後に、AI アプリケーションがベースプロトコルとして HTTPS を使用していることを確認し、AI セキュリティ ポリシーを厳格化できるようにします。 プロンプトを送信する際にHAR データを収集し、そのエントリをレビューしてプロンプトを含むリクエストを見つけます。 以下の例 (Microsoft Copilot) では、基礎となるプロトコルがWSS:// です。そのため、トラフィックは直接インターネットに送られ、Cato の AI セキュリティエンジンをバイパスします。
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