개요
소켓 배포는 Cato 클라우드에 사이트를 온보딩하는 첫 번째 중요한 단계입니다. 소켓이 클라우드에 등록되지 않으면 Cato에서 제공하는 기능을 사용하는 데 첫 번째 장애물이 됩니다. 이 연극책은 관리자가 소켓 배포 시 직면할 수 있는 문제를 해결하는 데 도움이 됩니다.
증상
소켓 등록 실패는 여러 가지 방법으로 나타날 수 있습니다. 관리자는 다음과 같은 증상을 알 수 있습니다:
- 소켓을 인터넷에 연결할 때 새로운 소켓 알림 없음
- 새 소켓 알림이 수신되었으나 초기 펌웨어 업그레이드 실패
- 소켓 할당 시 사이트를 찾을 수 없음
- 소켓이 사이트에 성공적으로 등록되었으나 사이트가 곧 오프라인 상태로 전환됨
- 사이트에서 소켓을 할당 해제한 후 다시 할당할 수 없음
가능한 원인
등록 실패의 대다수는 다음과 같은 원인에 해당됩니다:
- 소켓과 CMA 간의 등록 불일치
- DTLS 터널 연결 문제
- 예약된 라이센스로 인해 사이트 오프라인.
문제 해결
관리자가 직면할 수 있는 증상을 해결하기 위한 단계는 아래에 나열되어 있습니다. 이 단계는 직면한 문제의 가능한 원인을 식별하기 위한 것입니다. 해결 단계는 나중에 연극책에서 강조 표시됩니다.
소켓 연결 시 새 소켓 알림 없음에 대한 문제 해결
신규 소켓이 처음 인터넷에 연결되면 Cato에 연결하여 관련 펌웨어로 업그레이드를 시작합니다. 이는 구매 시 할당된 계정에 알림으로 표시됩니다.
이 알림을 수신하지 못하면 연결이 성공적으로 완료되지 않았음을 나타냅니다.
소켓 연결성 확인
Cato 소켓 연결 사전 요건에 익숙한지 확인하십시오.
소켓의 연결 상태는 자체 로컬 웹UI에서 확인할 수 있습니다. 소켓 웹UI 로컬로 로그인하기. 등록이 성공할 수 있으려면 Cato 클라우드로의 연결 서비스를 위해 사용 중인 WAN 포트에 녹색 상태 아이콘이 표시되어야 합니다. 녹색이 아닌 경우 연결 문제를 나타냅니다. 다양한 상태 아이콘 색상의 의미는 링크 상태 아이콘 이해에서 설명되어 있습니다
빨간색 아이콘의 경우 소켓과 ISP 장치 간에 작동하는 물리적 링크가 있는지 확인하십시오.
경고 아이콘은 IP 충돌과 같은 다른 유형의 연결 문제를 나타냅니다. WebUI에서 IP 충돌 문제를 보고하는 경우 IP 주소 충돌보고를 참조하십시오
연결 문제 발생 시 추가 테스트를 위해 도구 탭을 사용할 수 있습니다. 카토에 등록하기 위해 소켓은 호스트명 cc2.catonetworks.com 또는 하드코딩된 IP 주소를 사용하여 CMA에 L3 접근 권한이 필요합니다. IP 주소를 식별하려면 카토 관리 애플리케이션의 소스 IP 주소를 참조하십시오(이 문서를 보려면 로그인해야 합니다). 핑 도구를 사용하여 이 호스트명과 IP 주소가 WAN 포트를 통해 직접 연결 가능한지 확인합니다. 접속할 수 없는 경우 연결성 문제 해결 섹션을 확인하십시오.
WAN IP 주소가 업스트림 방향에서 수행되는 SSL/TLS 검사에서 제외되었는지 확인하십시오.
이 테스트가 통과하면 패킷 캡처도 수행하여 소켓의 CMA에 대한 등록 요청에 응답이 있는지 확인할 수 있습니다. 해당 WAN 포트에서 캡처할 때, CMA로의 TCP/443 및 PoP로의 UDP/443에 대한 양방향 패킷이 확인되어야 합니다.
cc2.catonetworks.com에 대한 TCP 연결
PoP로의 UDP 연결
아웃바운드 DTLS 패킷만 감지되는 경우, 한 방향의 DTLS 트래픽 문제 해결을 참조하십시오.
소켓 등록 상태 확인
인터넷 연결이 있는 새로운 소켓이 계정에 알림을 생성하려면 관련 계정에 할당되어야 합니다. 계정에 할당된 모든 소켓의 등록 상태를 확인하려면 계정 > 소켓 인벤토리에서 소켓 인벤토리를 보세요.
주어진 소켓의 MAC 또는 일련 번호를 검색하여 소켓이 계정에 올바르게 할당되었는지와 CMA의 현재 등록 상태를 확인할 수 있습니다. 관리자가 새로운 소켓을 인터넷에 연결할 때, 소켓이 배송 완료에서 설치됨 상태로 이동할 것으로 기대할 수 있으며, 이는 계정의 모든 소켓 보기(소켓 인벤토리)에서 설명됩니다
만약 소켓이 인벤토리에 나타나지 않거나 소켓 등록 상태가 작동하는 인터넷 연결에 연결되어도 설치됨으로 이동하지 않는다면 등록 불일치 설정 해결 섹션을 참조하십시오.
가상 소켓 등록
물리적 소켓과 달리, vSocket은 계정의 소켓 인벤토리에 사전 추가할 필요가 없습니다. CMA에서 vSocket 사이트가 생성되면, 클라우드 플랫폼에 배포될 때까지 '보류 중' 상태에 들어갑니다.
배포가 성공적으로 완료되고 WAN 인터페이스를 통한 인터넷 액세스 후, vSocket은 자동으로 카토 클라우드에 등록되며, CMA에서 '새로운 소켓 감지' 알림을 트리거하며 vSocket의 WAN 공인 IP를 포함합니다.
이 알림이 나타나지 않으면 다음 문제 해결 단계를 따르십시오:
- 인터넷 액세스 확인 – vSocket의 WAN 인터페이스에 인터넷 액세스가 있는지 확인하십시오. 네트워크 보안 그룹(NSG) 규칙과 WAN 서브넷 라우팅 테이블에서 제한 사항을 확인하십시오.
- vSocket 재시작 – 클라우드 플랫폼에서 vSocket 인스턴스를 재부팅해 보세요.
- 최후 수단으로 다시 배포 – 문제가 지속되면, CMA에서 vSocket 등록을 취소하고 → 사이트 설정 → 소켓을 클릭한 후 다시 배포하십시오. 다시 배포 후 알림을 위해 CMA를 모니터링합니다.
초기 펌웨어 업그레이드 실패 문제 해결
새로 배포된 소켓이 처음 인터넷에 연결되면 WAN 포트를 통해 TCP/443 포트를 사용하여 계속해서 카토에 연결을 시도하며 펌웨어 버전을 업그레이드하려고 시도합니다.
CMA에 "소켓 성공적으로 업그레이드됨" 또는 "새 소켓 활성화" 알림이 없으면 소켓 연결성 확인의 문제 해결 단계를 확인하여 소켓의 인터넷 연결이 올바르게 서비스되고 있는지 확인하십시오
소켓의 연결성이 위의 단계에서 확인되면 등록 상태 불일치 해결 섹션을 확인하십시오.
소켓 할당 시 사이트 없음 문제 해결
소켓 관리에서 언급했듯이, CMA에서 '새 소켓' 알림을 받으면 다음 단계는 소켓을 이미 구성된 사이트에 할당하는 것입니다. 그러나 구성된 사이트가 표시되지 않거나 창에 '결과 없음'이 표시되는 경우, 사이트의 일반 설정에 구성된 연결 유형이 사이트에 설치된 소켓 모델과 일치하는지 확인하십시오.
예를 들어, 사이트가 연결 유형으로 X1600 LTE 소켓으로 구성된 경우, 사이트에 설치된 소켓 모델은 X1600 LTE 모델이어야 합니다.
성공적으로 등록된 후 곧바로 오프라인 되는 소켓 문제 해결
소켓의 연결이 여전히 유지되는지 확인하십시오.
새 소켓 감지 알림을 받은 후 초기 펌웨어 업그레이드가 성공적으로 완료되고 잠시 후 소켓이 오프라인이 되는 경우, 다음을 확인하십시오.
- CMA의 계정 > 라이센스 > 대역폭에서 플랜 열에 표시된 라이센스가 평가판 또는 상업용인지 확인하십시오.
- 라이센스 상태가 예정됨으로 설정되어 있으면 소켓이 사이트에 추가된 후 연결이 끊어집니다. 예정된 라이센스에 대한 자세한 내용은 계정 및 사이트를 위한 라이센스 수명 주기를 참조하십시오.
라이센스가 예약된 경우, 예약된 라이센스로 인해 사이트가 오프라인으로 전환 해결 섹션을 확인하세요.
라이센스가 올바른 경우, 등록 불일치 설정 해결에서 설명한 재설정 프로세스를 따르세요
사이트에서 할당 해제 후 할당할 수 없는 소켓 문제 해결
사이트에서 소켓 할당 해제는 소켓을 다른 사이트에 할당할 수 있게 만드는 주요 작업입니다. 그러나, 이것은 소켓이 온라인 상태일 때 완료해야 합니다. 할당 해제 후, 소켓이 알림 내에서 신규로 감지되지 않으면, 이 문제 해결 흐름을 따르세요.
CMA와 소켓에서 등록 상태 확인
계정에 할당된 모든 소켓의 등록 상태를 확인하려면 계정 > 소켓 인벤토리에서 소켓 인벤토리를 참조하십시오.
지정된 소켓의 MAC 또는 시리얼을 검색하여, 소켓이 사이트에서 제대로 할당 해제되었는지 CMA의 관점에서 확인할 수 있습니다. 관리자는 할당 해제된 소켓이 설치됨 상태로 이동할 것으로 기대해야 합니다.
CMA에 따르면 소켓의 등록 상태는 소켓의 자체 보기와 일치해야 합니다. 소켓의 보기는 소켓의 웹UI에 접속하여 확인할 수 있습니다, 소켓 웹UI에 로컬로 로그인하기.
소켓의 등록 대상은 아래에 표시된 위치에서 ' | <sitename>.<accountname> | ' 형식으로 WebUI의 메인 페이지에 표시됩니다.
이것이 소켓의 등록 해제를 설명하지 못한 경우, 소켓 연결 확인에 설명된 문제 해결 흐름을 따르세요.
연결성이 양호하면 등록 상태 불일치 해결 섹션을 확인하십시오.
발견된 문제 해결
연결 문제 해결
연결 문제가 소켓에만 영향을 미치는지 격리하는 것이 중요합니다. 같은 ISP 연결에 노트북을 연결하면, DNS 해결 또는 주소 핑 문제와 같은 문제가 발생합니까? 그렇다면, 진행을 위해 ISP에 연락하세요.
연결 문제가 소켓으로만 격리된 경우, WebUI의 네트워크 설정 탭에서 IP 구성이 올바른지 확인하세요:
이 설정이 올바른 경우, UDP 포트 443에서의 DTLS 트래픽이 인터넷으로 송신되는 것이 허용되는지 공급업체와 확인하세요. 필요한 경우, Cato PoP에 연결하기 위해 다른 포트 설정에서 설명한 대로 이 포트를 변경할 수 있습니다.
DTLS 트래픽 단방향 해결
공급업체와 UDP 포트 443에서의 DTLS 트래픽이 인터넷으로 송신되는 것이 허용되는지 확인하세요. 필요한 경우 이 포트는 Cato PoP에 연결하기 위한 다른 포트 설정에 설명된 대로 변경할 수 있습니다.
등록 불일치 설정 해결
CMA와 소켓의 등록 상태가 불일치할 경우, 소켓 재설정을 수행하여 등록 프로세스를 다시 시작할 수 있습니다. 재설정을 수행하기 전에 먼저 소켓이 이전에 사이트에 등록되었는지 확인하십시오.
정보 탭에서는 이전에 사이트에 등록되지 않은 소켓이 아래와 같이 "CC2에 아직 등록되지 않음"이라는 메시지를 표시합니다:
사이트에 등록되지 않은 소켓은 리셋/FD 버튼을 30-35초 동안 눌러서 소켓을 재설정하십시오, 관리자 비밀번호 재설정 및 소켓 재설정에 설명된 대로입니다.
사이트 등록이 있는 소켓의 경우, 소켓이 Cato 클라우드에 연결되지 않은 동안 관리 탭에서 '할당 해제'를 클릭하여 소켓을 재설정하십시오.
두 경우 모두 소켓이 CMA의 할당된 사이트에서 할당 해제되었는지 확인하십시오.
예약된 라이선스로 인해 사이트가 오프라인으로 전환되는 문제 해결
라이선스 업데이트를 위해 카토 SE 또는 CSM 대리인에게 연락하십시오.
Cato 지원에 문의하기
이 플레이북을 따른 후에도 문제가 해결되지 않으면 위의 문제 해결 단계 결과와 함께 지원 티켓을 제출하십시오. 연결 테스트 결과와 위의 지침에 따른 재설정 수행 여부 확인을 포함하십시오.
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