소켓 HA 상태 문제 해결

개요

고가용성은 소켓 장치의 심각한 장애 발생 시 중복성을 제공합니다. 사이트는 이러한 경우 소켓 장치 간의 전환이 성공적으로 이루어져 비즈니스 연속성이 유지되어야 합니다. 이 운영안내서는 이 시나리오의 문제 해결을 돕기 위해 제작되었습니다.

증상

소켓 HA 상태 준비되지 않음은 여러 방식으로 나타날 수 있습니다. 관리자가 다음 증상을 발견할 수 있습니다:

  • HA 쌍 멤버 소켓 중 하나가 오프라인 상태입니다.
  • '킵얼라이브'로 인해 HA 상태 준비되지 않음.
  • '호환 버전'으로 인해 HA 상태 준비되지 않음.

가능한 원인

  • HA 쌍 중 하나가 Cato와의 연결성에 문제가 있습니다.
  • 소켓들 간의 LAN 측 연결 부족
  • 소켓들 간의 펌웨어 차이

문제 해결

관리자가 마주할 수 있는 증상 문제를 해결하는 단계가 아래에 나열되어 있습니다. 이 단계는 직면한 문제의 가능한 원인을 식별하는 데 목적이 있습니다. 해결 단계는 이후에 운영안내서에서 강조될 것입니다.

소켓 HA 구성원이 오프라인인 문제 해결

우리의 소켓 연결성 문제 해결 운영안내서를 따르십시오.

 

'킵얼라이브'로 인해 HA 상태 준비되지 않음 문제 해결

LAN 인터페이스 상태

VRRP 메시지, HA 쌍 간 HA 상태를 유지하기 위한 메커니즘, 각 구성원의 LAN 인터페이스 간의 네트워크 경로가 필요합니다. VRRP 메시지에 사용할 LAN 포트가 연결되고 사용 가능한지 확인하십시오. 

VLAN 설정이나 물리적 배선의 변경과 같은 스위치나 LAN 측 구성의 최근 변경을 확인하십시오. 귀하의 구성이 소켓 고가용성 (HA)이란 무엇인가에 설명된 소켓 HA의 모범 사례를 따르고 있는지 확인하십시오.

 

VRRP 프레임 전송 및 수신

How to Take a Packet Capture on a Socket,에 나열된 절차를 따라 두 소켓의 LAN 인터페이스에서 패킷 캡처를 실행하고 기본 소켓이 대기 소켓으로 VRRP 유지 메시지를 보내고 있는지 확인합니다.

소켓 HA 상태가 준비되려면 다음 두 가지 조건이 모두 충족되어야 합니다:

  • 기본 소켓은 VRRP 메시지를 전송해야 합니다
  • 보조 소켓은 그러한 VRRP 메시지를 수신해야 합니다

기본 소켓이 이러한 메시지를 보내지만 보조 소켓이 수신하지 않는 경우, 보조 소켓에 도달하지 못하도록 하는 요인이 있는지 확인하기 위해 로컬 네트워크 인프라를 조사하십시오.

 

'호환 버전'으로 인해 HA 상태 준비되지 않음 문제 해결

이것이 펌웨어 업그레이드 실패로 인해 발생한 경우, 소켓 업그레이드 실패 문제 해결 운영안내서의 업그레이드 실패 후 터널 설정됨 프로세스를 참조하십시오

 

호환되지 않는 버전 해결로 이동하십시오.

 

발견된 문제 해결

호환되지 않는 버전 해결

순간적인 연결성 문제가 업그레이드 실패의 원인이 되었을 수 있으며 두 번째 시도에서는 성공할 수 있습니다. 새 소켓 업그레이드를 시도하려면, 사이트 설정 > 소켓 > 작업 > 업그레이드에서 수동으로 업그레이드를 시작합니다.

대상 버전이 HA 쌍의 두 소켓이 같은 버전을 갖도록 할 것임을 확인하십시오. 이 도구는 펌웨어 버전을 업그레이드할 수만 있으며 다운그레이드할 수 없습니다. 수동 펌웨어 업그레이드 시작 후 17분 후, CMA는 "성공적으로 업그레이드되었습니다"라는 알림을 표시하여 소켓이 유예 기간 후 성공적으로 업그레이드되었음을 알립니다.

이번 업그레이드도 실패하면, 소켓 업그레이드 실패 문제 해결 운영안내서를 활용하십시오

 

Cato 지원에 사례 제출

이 플레이북을 따라도 문제가 해결되지 않은 경우, 지원 티켓을 제출하십시오. 요청에 대한 가장 유용한 대응을 얻으려면, 관리자는 이 플레이북을 사용할 때 수행한 문제 해결 단계의 결과를 제공해야 합니다. 예시를 포함하여:

  • 타임스탬프를 포함한 수동 업그레이드의 확인.
  • VRRP 메시지의 전송 및 수신 확인.
  •  
  •  

도움이 되었습니까?

0명 중 0명이 도움이 되었다고 했습니다.

댓글 0개