Problema
Em alguns casos, políticas de segurança de IA são aplicadas a determinadas aplicações de IA, mas não em outras quando a Extensão do Navegador está conectada. Por exemplo, políticas podem ser aplicadas ao ChatGPT, mas não à Microsoft Copilot, mesmo que ambas as aplicações estejam ativadas dentro da mesma política. Este artigo explora o motivo por trás desse comportamento.
NOTA: Este estudo de caso foca na Extensão do Navegador Cato no contexto de segurança de IA e não deve ser confundido com o Plugin de Navegador Segurança de IA.
Causa Raiz
A Extensão do Navegador Cato atualmente suporta apenas tráfego HTTPS. Tráfego não-HTTPS não é roteado através da Cato, e, portanto, as políticas de segurança de IA não podem ser aplicadas.
Solução de Problemas
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Verifique se uma política está configurada sob a Política de Interação do Usuário para o tráfego relevante. No CMA, vá para Segurança de IA > Política de Interação do Usuário. Para casos de uso de extensão do navegador, assegure-se de que a política está definida com uma Regra de Rede como o tipo de interceptação.
- Verifique se a aplicação é suportada pela Cato e está listada no menu suspenso dentro da regra de interceptação de rede.
- Finalmente, confirme que a aplicação de IA usa HTTPS como o protocolo subjacente para que as políticas de segurança de IA possam ser aplicadas. Capture dados HAR enquanto envia um prompt, depois reveja as entradas para localizar o pedido que carrega o prompt. No exemplo abaixo (Microsoft Copilot), o protocolo subjacente é WSS://; portanto, o tráfego é enviado diretamente para a Internet, ignorando o motor de segurança de IA da Cato.
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