Ошибка сети Zscaler при подключении через клиент Cato SDP

Проблема

Коннектор клиента Zscaler сталкивается с отказом подключения при использовании вместе с клиентом Cato SDP, отображая сообщение об ошибке "Не может быть обнаружен сетевой интерфейс."

Среда

  • Клиент SDP подключен к Cato Cloud.
  • Версия приложения клиента Zscaler 4.1.

Причина

Ошибка подключения связана с проблемой совместимости между клиентом SDP и версией 4.1 приложения клиента Zscaler.

Когда клиент SDP подключен, он присваивает IP-адрес 169.254.x.x (по умолчанию 169.254.254.1) в качестве адреса шлюза для маршрутизации трафика через туннель. Однако, когда клиентский коннектор Zscaler версии 4.1 и выше обнаруживает использование локального IP-адреса как следующего перехода, он блокирует соединение Zscaler.

Из журналов клиента zScaler ошибка выглядит следующим образом:

2023-08-14 16:54:44.117118(+0530)[11896:11880] ERR Шлюз интерфейса по умолчанию: 169.254.254.1

Эта проблема будет продолжаться, даже если публичный IP облака Zscaler обойдён из туннеля Cato (раздельный туннель).

Решение

Проблема решена в версии Zscaler 4.2 или выше.

Была ли эта статья полезной?

Пользователи, считающие этот материал полезным: 3 из 3

0 комментариев