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SDPクライアントがリモートWANリソースへの接続に失敗する

問題

SDPクライアントはCatoを介してリモートWANリソース、例えばネットワークドライブに接続できません。 接続の試行がタイムアウトするか、宛先に到達しません(例:pingが失敗します)。

根本原因

この問題は一般的にSDPクライアントのローカル(ホーム)ネットワークとリモートサイトでホスティングされているWANリソース間のサブネットの重複が原因です。 ほとんどのホームルーターはデフォルトのIP範囲として192.168.0.0/24192.168.1.0/24、または10.0.0.0/24を使用します。 リモートネットワークが同じ範囲で設定されている場合、クライアントはトラフィックをCatoトンネルを通さずにローカルにミスルートする可能性があり、接続に失敗します。

トラブルシューティング

  1. クライアントのローカルサブネットとリモートリソースのサブネットを比較します。 重複している場合、ルーティングの競合が問題の原因である可能性があります。
  2. Windowsクライアント(v5.3以上)では、LAN アクセス機能を使用してローカルLANへのアクセスをブロックします。 これにより、LAN経由のトラフィックを含むすべてのトラフィックが安全なCatoトンネルを通るようになり、ローカルリソースとの競合を避けることができます。
  3. macOSやLinuxなどの他のOSのSDPクライアントは、LAN アクセスブロック機能をサポートしていません。 代わりに、CMAでスプリットトンネルポリシーを設定して、トラフィックを明示的にトンネル経由でルートするようにします。
    • 必要なリモートサブネットをCMAのIP範囲として定義します(例:範囲の名称をHome-LANとします)。
    • すべてのトラフィックをトンネル可能にするために、デフォルトルート(0.0.0.0/0)として2番目のIP範囲を追加します。
    • これらのIP範囲を“例外”セクションにあるスプリットトンネルポリシーに適用し、“すべてのトラフィックをトンネル外にルーティング”します。 ポリシーで適用可能なOSプラットフォームを指定します。
    • 特定のシステムにのみ影響がある場合、個々のリモートホストのために/32 IP範囲を定義する必要があることがあります。

ベストプラクティス推奨

  • 可能であれば、企業または支社のネットワークをより一般的でないIP範囲を使用するように設定し、ホームLANとの競合リスクを最小限に抑えます。
  • または、ユーザーにホームルーターのDHCP設定を変更して、あまり一般的でないIP範囲を割り当てるよう指示します。

サブネット重複問題を特定し解決することで、SDPクライアントを介したリモートWANアクセスの信頼性と一貫性を大幅に向上させることができます。 内部リソースへのアクセス問題に関する追加のヘルプについては、 内部リソースへのアクセスのトラブルシューティングをご覧ください。

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