Browser Access Portal Troubleshooting

 

Visão Geral

Os Portais de Aplicações (também conhecidos como Acesso ao Navegador) permitem que usuários acessem seus recursos corporativos internos estabelecendo um túnel seguro via Internet. Este serviço não requer uma conexão SDP, mas exige que os usuários sejam Usuários SDP licenciados. Este manual discute problemas comuns de Acesso ao Navegador e fornece etapas de solução de problemas para abordá-los.

Sintomas

  • Usuário acessando o Portal de Aplicações recebe uma Página de Acesso Negado

  • O aplicativo não aparece no Portal de Acesso ao Navegador
  • O aplicativo não carrega.
  • Conteúdos ausentes em aplicativos da web

  • Formato incorreto de conteúdos em aplicativos da web. Por exemplo, os elementos estão dispostos aleatoriamente na página, o texto está no tamanho de fonte errado, as imagens não estão corretamente alinhadas, etc.

  • Os aplicativos atingem tempo limite para o Acesso ao Navegador; os usuários do cliente SDP operam normalmente.

Possíveis Causas

  • Configurações incorretas
  • Uso do protocolo HTTP e o aplicativo da web contém links HTTP absolutos para outros conteúdos

Solução de Problemas

Esta seção investigará as etapas para solucionar problemas comuns do Portal de Aplicações.  

Usuários Não Podem Acessar o Portal de Aplicações

Quando o usuário acessa o Portal de Aplicações usando a URL do Portal especificada em Acesso > Portal de Aplicações > Configurações, eles são recebidos com a mensagem de Acesso Negado.

  1. Validar que o subdomínio não contenha caracteres especiais. Caracteres como hifens não são suportados. Consulte Alterar o subdomínio para excluir caracteres especiais para obter instruções sobre como validar que caracteres especiais são usados no Subdomínio.
  2. Verifique se o usuário é um Usuário SDP (licenciado). Apenas usuários que receberam uma licença podem acessar o Portal de Acesso ao Navegador. Consulte Atribuição de licença aos Usuários para instruções sobre como validar isso.  
  3. Se a autenticação SSO estiver ativada e "Permitir login com Single Sign-On" estiver marcado (Acesso > Single Sign-On), verifique se o domínio do usuário está incluído nos Domínios Permitidos.
     
  4. Verifique nos Eventos qualquer erro óbvio. Vá para Inicial > Eventos e adicione um Filtro conforme mostrado abaixo. 

    Todos os eventos relacionados ao portal de acesso do navegador serão mostrados. Abaixo está um exemplo de um evento de acesso negado.  

Aplicações Não Apareceram na Página Inicial da Aplicação

Quando o usuário faz login no Portal de Acesso ao Navegador, aplicações específicas não aparecem.

  1. Valide se a aplicação foi adicionada em Acesso > Portal de Aplicações > Aplicações. Se não for adicionada lá, não será refletida na página inicial do Portal de Aplicações.
  2. Certifique-se de que o usuário tenha acesso à aplicação. Caso contrário, ele não poderá vê-la na página inicial da aplicação. Isso pode ser feito em Acesso > Portal de Aplicações > Regras de Acesso.
  3. Para obter instruções sobre a resolução desses problemas, consulte Adicionar aplicação ao portal de acesso ao navegador e Configurar regras de acesso para usuários permitidos.

A Aplicação Falha ao Carregar

Ao clicar no ícone da Aplicação, o navegador pode não mostrar conteúdo e a Aplicação continua carregando até que expire.

Se o acima ocorrer, colete os seguintes dados:

  1. Colete uma captura PCAP do Socket do site onde o servidor de aplicação está hospedado, conforme explicado em Como Capturar Tráfego em um Socket. Filtre o Endereço IP do servidor web e a porta 80 ou 443, dependendo da porta configurada para a aplicação no CMA.
  2. Confirme se há fluxo de tráfego TCP do servidor web. Caso contrário, verifique a conectividade local com o servidor. Sem NAT, o tráfego que chega ao seu servidor interno virá de um Endereço IP Público.
  3. Verifique se é necessário usar a Faixa de IPs NAT para roteamento adequado para/de a rede interna. Sem Faixa de IPs NAT, o tráfego que chega ao servidor interno virá de um Endereço IP Público.
  4. Se o tráfego TCP for visto na etapa #2, colete um arquivo HAR através do Portal de Acesso ao Navegador ao acessar a aplicação, seguindo estas etapas:
    1. No portal de acesso ao navegador, clique com o botão direito em qualquer lugar da página e selecione "Inspecionar" no menu de contexto.
    2. Clique no botão de configurações localizado no canto superior direito. Esta opção está disponível no Chrome. Se estiver usando um navegador diferente, prossiga para a etapa #4.

    3. Em Preferências > Global, selecione 'Abrir DevTools automaticamente para popups'.
    4. Clique na aplicação a partir do portal de acesso ao navegador. Uma segunda aba será aberta. É aqui que a gravação deve ocorrer. A menos que seu navegador grave automaticamente a partir desta segunda guia (etapa #3), você precisará realizar esta ação manualmente na próxima etapa.
    5. Siga as instruções de Como-coletar-Dados-HAR para reproduzir o problema e coletar o arquivo HAR.
    6. Envie esta informação para o Suporte Cato para investigação adicional. Veja Levantando casos ao Suporte Cato
  5. Se o arquivo HAR mostrar um redirecionamento para um domínio interno, o Navegador Externo não conseguirá resolvê-lo pois não faz a resolução DNS com a rede interna. Esta é atualmente uma limitação da solução de Acesso ao Navegador, e o usuário deve se conectar ao Cato através do Cliente SDP.

Envie esta informação para o Suporte Cato para investigação adicional. Veja Levantando casos ao Suporte Cato.

A Aplicação Web Apresenta Problemas de Formatação

A formatação da aplicação web é problemática, com elementos colocados de maneira desordenada na página, o texto exibindo tamanhos de fonte inconsistentes, e imagens aparecendo desalinhadas. Este problema pode surgir quando um cliente acessa uma aplicação web através do Portal de Acesso ao Navegador usando o protocolo HTTP, e o código HTML da aplicação web inclui links HTTP absolutos para outros conteúdos. Porque a conexão do Portal de Acesso ao Navegador opera em HTTPS, navegadores web contemporâneos restringirão o acesso a conteúdo HTTP, comumente referido como "conteúdo misto."

Siga estas etapas para verificar se está encontrando este problema.

  1. Você pode coletar o arquivo HAR através do Portal de Acesso ao Navegador enquanto acessa a aplicação. Para obter instruções detalhadas, consulte Como-coletar-Dados-HAR.
  2. Se este for o problema, as ferramentas de desenvolvedor web exibirão blocos de conteúdo misto, acompanhados por um aviso indicando que a conexão com o site não é segura.

  3. Clique com o botão direito em qualquer lugar da página e selecione "Ver Código Fonte da Página" Isso abrirá o código fonte do site.
  4. Examine para qualquer link começando com "http://" conforme ilustrado abaixo:
    <link href="http://nms-ubuntuserver.via.catonetworks.com/css/bootstrap.min.css" rel="stylesheet" type="text/css" />

  5. A presença de links HTTP no código fonte é a razão pela qual o navegador está bloqueando o conteúdo.
  6. Siga as sugestões descritas em Problemas de Formatação para resolver este problema.

Os aplicativos atingem tempo limite para o Acesso ao Navegador; usuários do cliente SDP ou usuários de sites podem acessar normalmente.

O portal carrega, mas os aplicativos por trás dele não abrem. Usuários no aplicativo SDP baseado em cliente ou usuários por trás de Cato sockets podem acessar tudo normalmente. Usuários que acessam pelo Acesso ao Navegador enfrentam tempo limite ao tentar abrir qualquer aplicação.

Nota: O acesso remoto baseado em navegador não suporta sobreposição de IPs entre um intervalo de IP SNAT e o intervalo de IP para o site.

Por exemplo, o Acesso ao Navegador está usando um intervalo NAT como 10.60.10.0/24. Ao mesmo tempo, sua rede está anunciando uma rota mais ampla, como 10.0.0.0/8, para o Cato. Como 10.60.10.0/24 está dentro desse bloco 10.0.0.0/8, a plataforma vê o tráfego retornado como sobreposição com a própria sub-rede do site. Quando o tráfego tenta voltar para um usuário do Acesso ao Navegador, a plataforma o descarta para evitar a criação de um loop de roteamento, uma vez que a rota mais ampla /8 puxaria o pacote de volta para o site em vez de para o usuário. Essa sobreposição impede que a plataforma instale uma rota de retorno limpa para o tráfego do Acesso ao Navegador.
 

Para resolver o problema, valide as Rotas SNAT e de Conta

  1. Identifique o intervalo de IP SNAT configurado para o Acesso ao Navegador.

  2. Navegue até a Tabela de Roteamento em sua conta > rede. Verifique todas as rotas de conta e confirme que nenhuma sobreposição ocorre com o intervalo SNAT. Sem dados significa que não existe sobreposição na tabela de roteamento. 

  3. Se uma sobreposição existir:
    • Ajuste a configuração de roteamento para remover o conflito.
    • Certifique-se de que as rotas anunciadas pelo BGP não cobrem o intervalo SNAT.

Resolvendo Problemas Descobertos

Configuração Incorreta

Muitos dos problemas mencionados acima estão relacionados à configuração. Uma vez identificadas as áreas configuradas incorretamente, resolvê-las deve resolver o problema.

Alterando o Subdomínio para Excluir Caracteres Especiais

Navegue até Acesso > Single Sign-On e certifique-se de que não há caracteres especiais no campo Subdomínio. Este requisito também é mencionado em Configurando-o-Portal-de-Acesso-ao-Navegador. Para mais informações sobre o impacto de alterar o subdomínio, consulte Alterando-seu-Nome-de-Conta-e-Subdomínio.

Atribuindo Licenças a Usuários

Navegue até Acesso > Usuários > Diretório de Usuários e valide que o Usuário acessando o portal de Acesso ao Navegador é um Usuário SDP Licenciado


Para atribuir uma Licença a um Usuário, consulte Atribuindo-Licenças-SDP-a-Usuários 

Adicionando uma Aplicação ao Portal de Acesso ao Navegador

Navegue até Portal de Aplicações > Aplicação e valide que a aplicação foi adicionada. Consulte Gerenciando-Aplicações-para-o-Portal-de-Acesso-ao-Navegador para obter detalhes de configuração.

Configurar Regras de Acesso para Usuários Permitidos

Navegue até Acesso > Portal de Aplicações > Regras de Acesso e valide que o usuário pode acessar as aplicações. Para obter detalhes de configuração, consulte Definindo-a-Política-de-Acesso-ao-Navegador

Problemas de Formatação

A solução envolve modificar o código fonte do aplicativo, pois o navegador é responsável por bloquear conteúdo misto, não o Cato. Recomenda-se ao cliente transformar links absolutos (aqueles que começam com http://) no código HTML em links relativos. Links relativos podem ser relativos ao protocolo ou relativos à raíz.
Por exemplo, se você tiver um link semelhante a:

href="http://www.mywebsite.com/css/stylesheet.css"

Um link relativo ao protocolo seria assim:

href="//www.mywebsite.com/css/stylesheet.css"

Um link relativo à raiz seria algo assim:

href="/css/stylesheet.css"

Para mais informações sobre links absolutos e relativos, você pode se referir a absolute-vs-relative-urls

Submeter casos para o Suporte Cato

Enviar um ticket de Suporte com os resultados das etapas de solução de problemas descritas acima. Para problemas relacionados ao acesso a aplicativos do portal do navegador, inclua também respostas para as seguintes perguntas:

  1. Qual é o servidor de aplicação afetado? (IIS, Nginx, etc.)
  2. A aplicação exige autenticação adicional?
  3. O usuário tem acesso aos logs ou arquivos de configuração da aplicação? Se sim, esses logs capturam o problema?
  4. Quais são as localizações a partir das quais os usuários estão se conectando ao portal SDP?
  5. Os usuários podem conectar-se à aplicação quando estão usando o Cliente Cato ou quando estão atrás de um site de Socket?
  6. Existe um balanceador de carga/servidor de API/firewall entre eles? 

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