Устранение неполадок VoIP

Обзор

Этот справочник предоставляет руководство по устранению неполадок для распространенных проблем VoIP. Он включает симптомы, такие как проблемы с регистрацией телефона и низкое качество звонков, с рекомендациями по устранению возможных причин, таких как проблемы с сетевым подключением и некорректные настройки. Шаги по устранению неполадок, изложенные здесь, направлены на помощь пользователям в изоляции и разрешении этих проблем.

Симптомы

  • Проблема регистрации телефона
  • Невозможно совершить исходящие звонки
  • Плохое качество связи (разрывы, однонаправленный звук, джиттер, искажение вызова)

Возможные причины

  • Проблемы с сетевым подключением
  • Некорректная конфигурация
  • Потеря пакетов
  • Аппаратные неисправности
  • Аккаунт телефона не настроен на сервере SIP 
  • На телефоне введено неправильное имя пользователя/пароль (401 Неавторизован)

Устранение проблемы

Этот раздел углубится в пошаговые инструкции по устранению ранее упомянутых симптомов. 

Телефоны не могут успешно зарегистрироваться на сервере VoIP 

Перед тем как углубляться в шаги по устранению неполадок с регистрацией VoIP, ниже показаны потоки между IP-телефоном и сервером SIP во время успешной регистрации (процесс в 4 этапа). 
  1. Телефон отправляет запрос на регистрацию на сервер SIP.
  2. Сервер отвечает сообщением 401 Неавторизован, запрашивая аутентификацию телефона.
  3. Телефон отправляет другой запрос на регистрацию, включающий учетные данные для входа.
  4. Если регистрация успешна, сервер отвечает сообщением 200 ОК.

Вот так это выглядит на снимке данных при регистрации VoIP. 

Теперь, когда мы понимаем, как работает регистрация телефона, давайте изучим шаги по устранению неполадок ниже, чтобы еще больше изолировать проблемы с регистрацией.

Разрешение имени сервера VoIP

Проверьте подключение и разрешение сервера VoIP, настроенного на телефоне.

  • Сначала проверьте, правильно ли настроен DNS-сервер на IP-телефоне. 
  • Затем запишите Полное доменное имя (FQDN) или IP-адрес VoIP-сервера, настроенного на телефоне
  • С устройства, находящегося в той же ЛВС, что и VoIP-телефон и настроенного с тем же DNS-сервером:
    • Используйте nslookup, чтобы проверить, разрешается ли FQDN сервера. 
    • Ping полное доменное имя/IP-адрес сервера 
  • Обратитесь к разделу Решение проблемы с DNS для получения подробных шагов по решению этой проблемы.

Опции DHCP

  • В некоторых установках IP-телефон должен загружать файлы конфигурации с ТФТП-сервера перед регистрацией. Это выполняется через опции DHCP. Проверьте, использует ли VoIP-телефон специфические опции DHCP, чтобы обеспечить наличие у него необходимой сетевой информации для регистрации и работы в сети. Это может включать опции 66 и 150 (информация о ТФТП-сервере) или опцию 43 (ТФТП, сервер вызовов, уровень 2 и приоритет DSCP). При необходимости свяжитесь с поставщиком VoIP для получения дополнительной информации.
  • Обратитесь к разделу Решение проблемы с опцией DHCP для получения инструкций по настройке опции DHCP, если это необходимо. 

Блокировка трафика SIP

  • Убедитесь, что порты SIP (UDP/5060 и UDP/5080) не заблокированы. В CMA, в разделе Домашняя > События, установите фильтр на Порт назначения 5060,5080, а Действие - Блокировать. В идеале, вы не должны видеть никаких событий блокировки.
  • Проверьте, блокирует ли Cato трафик VoIP по какой-либо причине. В CMA в разделе Домашняя > События установите фильтр на "Категория - Voip Видео" и "Действие - Блокировать."
  • Выполните сбор трафика на стороне ЛВС сокета. Ниже приведен PCAP, показывающий однонаправленный поток от IP-телефона к серверу SIP. Ответ от SIP-сервера к IP-телефону не получен, что может означать проблему маршрутизации, службу SIP не включена на целевом сервере или файервол блокирует соединение (WAN/Интернет).
  • Чтобы решить эту проблему, просмотрите правила файервола WAN/Интернет, которые могут блокировать SIP-трафик, и внесите необходимые изменения.
  • Если на CMA не наблюдаются события блокировки, то проверьте сеть для выявления устройств, которые могут блокировать это соединение

Неверное имя пользователя/пароль введены на телефоне (401 Unauthorized)

  • Если телефон не удается зарегистрировать и он неоднократно получает от сервера сообщения 401 Unauthorized, не получая ответа 200 OK, это может указывать на некорректную настройку учётной записи телефона на SIP-сервере или на неправильное имя пользователя и пароль, введённые на телефоне (см. регистрационный поток выше).
  • PCAP ниже показывает 401 несанкционированный доступ от SIP-сервера.
  • См. Решение 401 Unauthorized, как предотвратить это.

Зашифрованные SIP

  • Если используется TCP/5061, то, скорее всего, SIP зашифрован через TLS. В таких случаях убедитесь, что проверка TLS обходит SIP-сервер. 
  • Перейдите в Решение зашифрованного SIP, чтобы узнать, как разрешить это.

Невозможно Исходящие Звонки

IP Фрагментация

  • Проверьте, зарегистрированы ли телефоны на SIP-сервере, и убедитесь, что журналы приглашения SIP присутствуют как на телефонах, так и на SIP-сервере.
  • Попробуйте совершить вызов и выполните захват пакетов (PCAP) для анализа трафика на телефоне, сервере и сетевых устройствах. В частности, ищите сообщения SIP_INVITE.
  • Определите, фрагментированы ли пакеты UDP SIP сетью, и убедитесь, что фрагменты получены как телефонами, так и SIP-сервером. Обратите внимание, что по умолчанию Cato позволяет фрагментацию на уровне PoP, что является желаемым поведением.

Исходящий IP

  • При использовании разного исходящего IP для SIP-трафика могут возникать неожиданные проблемы, такие как невозможность совершать исходящие звонки или прерывания вызовов. Сетевые правила для SIP должны быть настроены на исходящие через один исходящий IP-адрес.
  • Проверьте метод маршрутизации для VoIP-трафика по сетевому правилу и убедитесь, что используется 1 и только 1 исходящий IP. Ниже показаны 2 исходящих IP-адреса. Хотя это обеспечивает избыточность, возникнут проблемы, если поток SIP проходит по разным IP-адресам NAT.
  • Чтобы подтвердить, что это является причиной проблемы, выполните захват PCAP, чтобы проанализировать трафик на телефоне, SIP-сервере и сетевом устройстве (поиск сообщений SIP_REGISTER).
  • Если сервер отвечает, вы можете проверить исходящий IP Cato в разделе Via заголовка сообщения в пакетах, отправленных сервером. Полученный IP является исходящим IP Cato, а RPort - это NAT исходного порта для выходящих пакетов из PoP.
  • For best practice, configure only 1 egress IP on the network rule for VoIP traffic when the SIP server is reachable via the Internet. Этого можно достичь, используя опцию NAT. Смотрите Выделение-IP-адресов-для-аккаунта как выделить публичный IP для вашей учетной записи.
  • Дополнительная конфигурация должна быть настроена в Расширенной Конфигурации, чтобы убедиться, что для VoIP-трафика используется только 1 исходящий IP. Для получения дополнительных сведений см. Решение Невозможности Совершать Исходящие Вызовы/Прерывание Вызова/Односторонняя Передача Голоса.

Плохое Качество Звонков

Плохое качество связи часто вызвано потерей пакетов или их отбрасыванием, высокой задержкой или повышенным джиттером в туннеле Cato. В этом разделе обсудим, как изолировать, связано ли это с Cato или это потенциально неправильная конфигурация.

Потеря Пакетов

  • Проверьте в сетевой аналитике потерю пакетов в входящем и исходящем трафике.
  • Если потеря пакетов совпадает с потерей пакетов на последней миле, это свидетельствует о проблеме с провайдером или возможной неисправности кабеля WAN. Это повлияет на весь трафик.
    Для детального устранения потерь пакетов - Как-устранить-потерю-пакетов 

Отброшенные Пакеты

  • Если мы видим высокий процент отброшенных пакетов в Сетевой аналитике, это связано с проблемой, связанной с QoS, и возможным сетевым перегрузкой. Перейдите в Сеть > Анализатор приоритетов, чтобы определить, какой класс отбросил пакеты. Разверните Класс (щелкните значок + для разворачивания) и проверьте Топ Приложений для VoIP трафика, чтобы убедиться, что VoIP трафик находится в том же классе.
  • Ознакомьтесь с разделом Решение отброшенных пакетов (QoS) для получения инструкций по присвоению VoIP высшего класса приоритета. 

Высокая Задержка/Джиттер

  • Для джиттера и задержки, проверьте Сетевую аналитику, чтобы выявить повышенную задержку или джиттер в туннеле Cato. Выполните PCAP по мере необходимости. ITU-T G.114 рекомендует менее 150 мс односторонней задержки для VoIP.
  • Если наблюдается высокий уровень задержки, убедитесь, что Сокет подключен к оптимальному PoP.
  • Если наблюдается высокий джиттер, QoS и Управление полосой пропускания также могут быть рассмотрены/пересмотрены для решения этой проблемы путем присвоения VoIP трафика высшему классу приоритета.

Односторонняя голосовая связь

  • При возникновении одностороннего звука выполните PCAP звонка и определите используемые IP/порты. SIP ALG может потребовать включения или отключения в зависимости от требований поставщика VoIP.
  • SIP ALG переводит приватный IP-адрес телефона/PBX на публичный IP-адрес Cato (и наоборот) в открытом SIP-сообщении после того, как Cato выполняет NAT. По умолчанию, в Cato SIP ALG отключен. Если вам нужны дополнительные детали, свяжитесь с поставщиком VoIP.
  • Ознакомьтесь с разделом Решение проблемы невозможности совершать исходящие звонки/Отмена звонка/Односторонняя голосовая связь для получения инструкций по включению ALG в Расширенной конфигурации.

Решение обнаруженных проблем

Решение проблем DNS

  • Если полное доменное имя (FQDN) сервера VoIP не удалось успешно разрешить, проверьте, что полное доменное имя сервера корректно.
  • Если полное доменное имя сервера VoIP корректно, проверьте правильность настроек DNS. Для получения инструкций по настройке DNS в Cato, ознакомьтесь с Настройкой DNS.
  • Пинг к серверу, используя его IP-адрес
  • Если пинг IP-адреса сервера VoIP не удался, проверьте соединение, проверив кабели и настройки WiFi.
  • Убедитесь, что сервер позволяет ICMP ping через Файервол
  • Убедитесь, что сервер подключен
  • Выполните трассировку маршрута и посмотрите, где происходит сбой.

Решение проблемы опции DHCP

  • Если для подключения VoIP телефона к загрузке конфигураций требуется определенная опция DHCP, её можно настроить в Сеть > DHCP > Опции DHCP. Для настройки опций DHCP для Групп ознакомьтесь с Настройкой Групповых Опций DHCP.

Решение проблемы с отброшенными пакетами (QoS)

  • Всегда убедитесь, что VoIP имеет наивысший приоритет для управления пропускной способностью (QoS), поскольку трафик с низким приоритетом будет отброшен при перегрузке.
  • Перейдите в Сеть > Управление пропускной способностью. По умолчанию, VoIP классифицируется как приоритет P10. Если вы определили другие классы более высокого приоритета (меньшие чем P10), рассмотрите возможность перемещения VoIP в класс с наивысшим приоритетом, чтобы избежать отброса в случае сетевой загрузки.
  • Настройка профилей управления пропускной способностью предоставляет подробную информацию о том, как настроить управление пропускной способностью в Cato. 

Решение проблемы потери пакетов

  • Если обнаружена потеря пакетов на последней миле, замените кабель, подключенный к WAN-порту сокета. Если это не решает проблему, свяжитесь с вашим интернет-провайдером для дальнейшего изоляции проблемы. 
  • Высокое использование сокетов может привести к потере пакетов. Если наблюдается постоянное высокое использование ЦП при потере пакетов в сети, пожалуйста, Связаться со службой поддержки.
  • Если в трафике VoIP наблюдается высокая потеря пакетов, рассмотрите возможность включения смягчения потерь пакетов. Для подробностей обратитесь к Оптимизация трафика.

Решение зашифрованного SIP

  • Примените правило обхода TLSi, чтобы предотвратить инспекцию TLSi трафика VoIP, если используется TCP/5061.

Решение 401 Неавторизованный

  • Успешная регистрация IP-телефонов зависит от точных конфигураций как сервера, так и клиента, а именно SIP-сервера и IP-телефона соответственно. Таким образом, точный ввод как SIP URI, так и пароля имеет решающее значение для успешной регистрации услуги. Проверьте, правильно ли они настроены на VoIP-телефонах.

Решение неудачных исходящих вызовов/Сброс вызова/Односторонняя связь

  • Если выбран исходящий IP, убедитесь, что включена настройка Предпочтительный IP для трафика SIP в разделе Ресурсы > Расширенная конфигурация. Когда включено, трафик SIP всегда выходит с того же IP-адреса, чтобы избежать временного NAT на разные исходящие IP, предотвращая потенциальные проблемы. Если исходящий IP недоступен (например, во время обслуживания PoP), пакеты отбрасываются. Убедитесь, что IP-телефоны сброшены после внесения этого изменения.
  • Если протокол VoIP не является SIP, пожалуйста, Связаться со службой поддержки для применения изменений на сервере, с целью принудительного удержания трафика на исходящем IP.
  • Если SIP ALG требуется, включите его в Ресурсы > Расширенная конфигурация

Решение субоптимального PoP

  • Убедитесь, что вы подключены к ближайшему PoP. Перейдите в Сеть > Сайт > Снимок. В разделе Обзор Устройства вы увидите провайдера связи и PoP подключения.
  • Если устройство не подключено к оптимальному PoP, проверьте, настроены ли «Предпочтительные местоположения PoP». Для этого перейдите в Сеть > Сайт > Настройки сайта > Общие > Предпочтительные местоположения PoP. Если настройка была задана неправильно, выберите оптимальное местоположение.

Передача дел в поддержку Cato

Если вышеуказанные шаги не помогли изолировать и решить проблему, пожалуйста, откройте дело в Поддержка Cato. При открытии дела рассмотрите следующие вопросы и предоставьте соответствующие ответы: 

  • У вас облачный провайдер VoIP или ваша телефонная система размещена локально?
    • Если облачный:
      • Где находятся затронутые телефоны (какой сайт Cato)?
      • Кто является провайдером VoIP?
      • Какой IP-адрес или URL сервера регистрации телефона?
    • Если локальный:
      • Где находятся затронутые телефоны (какой сайт Cato)?
      • Какой IP-адрес сервера регистрации телефона?
  • Какая проблема? Телефоны успешно регистрируются? Есть ли проблемы со звуком?
  • Если это аудиопроблема:
    • Слышат ли обе стороны рингтон?
    • Слышат ли обе стороны аудио?
    • Есть ли проблемы с качеством связи (прерывистый звук)?
  • Отключаются ли звонки преждевременно?
    • Отключаются ли звонки через определенное время?
    • Были ли звонки отключены в определенное время?
  •  

Была ли эта статья полезной?

Пользователи, считающие этот материал полезным: 3 из 3

0 комментариев